GOing round in circles with Wine

Discuss running non-Linux applications and plugins on Linux, for example via wine

Moderators: khz, MattKingUSA

User avatar
gauderbock
Established Member
Posts: 4
Joined: Thu Oct 04, 2018 1:01 pm
Location: Tirol

GOing round in circles with Wine

Postby gauderbock » Tue Jan 14, 2020 7:06 pm

Hi all.

My installation of Wine stopped working at around the same time KXStudio changed repositories. Dunno if that's related.

But since then I've been going round in circles trying to get a working install on Linux Mint 19. I'm trying to completely uninstall the current Wine so I can install the latest from WineHQ, but every attempt to uninstall results in an earlier version being forced on me (this happens both with synaptic and aptitude via command line).

I think the dependency list is borked somehow, prolly my own fault, but I don't know where to go from here... Any ideas anyone? Thanks.

Code: Select all

$ sudo aptitude remove wine-staging-i386:i386
The following packages will be REMOVED: 
  gstreamer1.0-plugins-base:i386{u} libasn1-8-heimdal:i386{u} libavahi-client3:i386{u} libavahi-common-data:i386{u}
  libavahi-common3:i386{u} libavcodec57:i386{u} libcap2:i386{u} libcapi20-3:i386{u} libcdparanoia0:i386{u}
  libcups2:i386{u} libexif12:i386{u} libfaudio0:i386{u} libgd3:i386{u} libgmp10:i386{u} libgnutls30:i386{u}
  libgphoto2-6:i386{u} libgphoto2-port12:i386{u} libgssapi-krb5-2:i386{u} libgssapi3-heimdal:i386{u}
  libgstreamer-plugins-base1.0-0:i386{u} libgstreamer1.0-0:i386{u} libhcrypto4-heimdal:i386{u}
  libheimbase1-heimdal:i386{u} libheimntlm0-heimdal:i386{u} libhogweed4:i386{u} libhx509-5-heimdal:i386{u}
  libidn2-0:i386{u} libk5crypto3:i386{u} libkeyutils1:i386{u} libkrb5-26-heimdal:i386{u} libkrb5-3:i386{u}
  libkrb5support0:i386{u} liblcms2-2:i386{u} libldap-2.4-2:i386{u} libltdl7:i386{u} libmpg123-0:i386{u}
  libnettle6:i386{u} libopenal1:i386{u} liborc-0.4-0:i386{u} libosmesa6:i386{u} libp11-kit0:i386{u}
  libroken18-heimdal:i386{u} libsasl2-2:i386{u} libsasl2-modules:i386{u} libsasl2-modules-db:i386{u}
  libsdl2-2.0-0:i386{u} libsndio6.1:i386{u} libsqlite3-0:i386{u} libssl1.1:i386{u} libstb0:i386{u}
  libtasn1-6:i386{u} libunistring2:i386{u} libusb-1.0-0:i386{u} libv4l-0:i386{u} libv4lconvert0:i386{u}
  libvisual-0.4-0:i386{u} libwayland-client0:i386{u} libwayland-cursor0:i386{u} libwayland-egl1:i386{u}
  libwind0-heimdal:i386{u} libxcomposite1:i386{u} libxcursor1:i386{u} libxi6:i386{u} libxinerama1:i386{u}
  libxkbcommon0:i386{u} libxpm4:i386{u} libxrandr2:i386{u} libxslt1.1:i386{u} libxss1:i386{u} libxxf86vm1:i386{u}
  wine-staging-i386:i386
0 packages upgraded, 0 newly installed, 71 to remove and 2 not upgraded.
Need to get 0 B of archives. After unpacking 477 MB will be freed.
The following packages have unmet dependencies:
 wine-staging:i386 : Depends: wine-staging-i386:i386 (= 5.0~rc5~bionic) but it is not going to be installed
 wine-staging-dev : Depends: wine-staging-i386 (= 5.0~rc5~bionic) which is a virtual package, provided by:
                             - wine-staging-i386:i386 (5.0~rc5~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (5.0~rc4~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (5.0~rc3~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (5.0~rc2~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (5.0~rc1~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.9~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.8~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.7~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.6~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.5~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.4~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.3~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.2~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.21~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.20~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.1~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.19~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.18~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.17~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.16~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.15~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.14~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.13~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.12~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.12.1~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.11~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.10~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.0~rc7~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.0~rc6~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.0~rc5~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.0~rc4~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.0~rc3~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.0~rc2~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.0~rc1~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.0~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.21.0~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.20.0~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.19.0~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.18.0~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.17.0~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.16.0~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.15.0~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.14.0~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.13.0~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.13.0-2~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.12.0~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.11.0~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.10.0~bionic), but it is not going to be installed

The following actions will resolve these dependencies:

     Remove the following packages:                   
1)     wine-staging:i386 [5.0~rc5~bionic (bionic, now)]
2)     wine-staging-dev [5.0~rc5~bionic (bionic, now)]

     Install the following packages:                   
3)     libwine-development [3.6-1 (bionic)]           
4)     wine-development [3.6-1 (bionic)]               
5)     wine64-development [3.6-1 (bionic)]             



Accept this solution? [Y/n/q/?]

User avatar
Michael Willis
Established Member
Posts: 908
Joined: Mon Oct 03, 2016 3:27 pm
Location: Rocky Mountains, North America
Contact:

Re: GOing round in circles with Wine

Postby Michael Willis » Tue Jan 14, 2020 8:12 pm

Are you using the wine stable repo? Find instructions about how to use it here: https://www.tecmint.com/install-wine-in-linux

That might be less trouble than trying to install the wine that comes from the Mint repo.

ubuntuuser
Established Member
Posts: 277
Joined: Mon Jan 02, 2017 9:46 am

Re: GOing round in circles with Wine

Postby ubuntuuser » Wed Jan 15, 2020 5:33 am

gauderbock wrote:Hi all.

My installation of Wine stopped working at around the same time KXStudio changed repositories. Dunno if that's related.

But since then I've been going round in circles trying to get a working install on Linux Mint 19. I'm trying to completely uninstall the current Wine so I can install the latest from WineHQ, but every attempt to uninstall results in an earlier version being forced on me (this happens both with synaptic and aptitude via command line).

I think the dependency list is borked somehow, prolly my own fault, but I don't know where to go from here... Any ideas anyone? Thanks.

Code: Select all

$ sudo aptitude remove wine-staging-i386:i386
The following packages will be REMOVED: 
  gstreamer1.0-plugins-base:i386{u} libasn1-8-heimdal:i386{u} libavahi-client3:i386{u} libavahi-common-data:i386{u}
  libavahi-common3:i386{u} libavcodec57:i386{u} libcap2:i386{u} libcapi20-3:i386{u} libcdparanoia0:i386{u}
  libcups2:i386{u} libexif12:i386{u} libfaudio0:i386{u} libgd3:i386{u} libgmp10:i386{u} libgnutls30:i386{u}
  libgphoto2-6:i386{u} libgphoto2-port12:i386{u} libgssapi-krb5-2:i386{u} libgssapi3-heimdal:i386{u}
  libgstreamer-plugins-base1.0-0:i386{u} libgstreamer1.0-0:i386{u} libhcrypto4-heimdal:i386{u}
  libheimbase1-heimdal:i386{u} libheimntlm0-heimdal:i386{u} libhogweed4:i386{u} libhx509-5-heimdal:i386{u}
  libidn2-0:i386{u} libk5crypto3:i386{u} libkeyutils1:i386{u} libkrb5-26-heimdal:i386{u} libkrb5-3:i386{u}
  libkrb5support0:i386{u} liblcms2-2:i386{u} libldap-2.4-2:i386{u} libltdl7:i386{u} libmpg123-0:i386{u}
  libnettle6:i386{u} libopenal1:i386{u} liborc-0.4-0:i386{u} libosmesa6:i386{u} libp11-kit0:i386{u}
  libroken18-heimdal:i386{u} libsasl2-2:i386{u} libsasl2-modules:i386{u} libsasl2-modules-db:i386{u}
  libsdl2-2.0-0:i386{u} libsndio6.1:i386{u} libsqlite3-0:i386{u} libssl1.1:i386{u} libstb0:i386{u}
  libtasn1-6:i386{u} libunistring2:i386{u} libusb-1.0-0:i386{u} libv4l-0:i386{u} libv4lconvert0:i386{u}
  libvisual-0.4-0:i386{u} libwayland-client0:i386{u} libwayland-cursor0:i386{u} libwayland-egl1:i386{u}
  libwind0-heimdal:i386{u} libxcomposite1:i386{u} libxcursor1:i386{u} libxi6:i386{u} libxinerama1:i386{u}
  libxkbcommon0:i386{u} libxpm4:i386{u} libxrandr2:i386{u} libxslt1.1:i386{u} libxss1:i386{u} libxxf86vm1:i386{u}
  wine-staging-i386:i386
0 packages upgraded, 0 newly installed, 71 to remove and 2 not upgraded.
Need to get 0 B of archives. After unpacking 477 MB will be freed.
The following packages have unmet dependencies:
 wine-staging:i386 : Depends: wine-staging-i386:i386 (= 5.0~rc5~bionic) but it is not going to be installed
 wine-staging-dev : Depends: wine-staging-i386 (= 5.0~rc5~bionic) which is a virtual package, provided by:
                             - wine-staging-i386:i386 (5.0~rc5~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (5.0~rc4~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (5.0~rc3~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (5.0~rc2~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (5.0~rc1~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.9~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.8~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.7~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.6~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.5~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.4~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.3~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.2~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.21~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.20~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.1~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.19~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.18~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.17~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.16~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.15~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.14~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.13~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.12~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.12.1~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.11~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.10~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.0~rc7~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.0~rc6~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.0~rc5~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.0~rc4~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.0~rc3~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.0~rc2~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.0~rc1~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (4.0~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.21.0~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.20.0~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.19.0~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.18.0~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.17.0~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.16.0~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.15.0~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.14.0~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.13.0~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.13.0-2~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.12.0~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.11.0~bionic), but it is not going to be installed
                             - wine-staging-i386:i386 (3.10.0~bionic), but it is not going to be installed

The following actions will resolve these dependencies:

     Remove the following packages:                   
1)     wine-staging:i386 [5.0~rc5~bionic (bionic, now)]
2)     wine-staging-dev [5.0~rc5~bionic (bionic, now)]

     Install the following packages:                   
3)     libwine-development [3.6-1 (bionic)]           
4)     wine-development [3.6-1 (bionic)]               
5)     wine64-development [3.6-1 (bionic)]             



Accept this solution? [Y/n/q/?]


I think it's because there are multiple parts that might need to be removed individually, one by one.

Try googling it.

Maybe sudo apt-get remove --autoremove wine-* might work on Debian based systems.

A list of wine packages that are installed can be viewed using apt list --installed | grep wine on Debian based systems.

Something like (I can't remember if the -amd64 is needed at the end of the name on the 64 bit packages ie winehq-staging-amd64, try it and see)

wine-staging-amd64

wine-staging-i386:i386

winehq-staging

wine-staging

Then when it's all uninstalled, follow the WineHQ install routine.

User avatar
gauderbock
Established Member
Posts: 4
Joined: Thu Oct 04, 2018 1:01 pm
Location: Tirol

Re: GOing round in circles with Wine

Postby gauderbock » Thu Jan 16, 2020 4:17 pm

Thanks all. I think I've finally removed all traces of the installation, basically by rejecting all suggestions and manually removing various libs etc that seemed to be stuck in dependency hell.

Now to try the WineHQ install again :wink:


Return to “Running non-linux software”

Who is online

Users browsing this forum: No registered users and 2 guests