Lin-vst problems (version mismatch)

Discuss running non-Linux applications and plugins on Linux, for example via wine

Moderators: khz, MattKingUSA

User avatar
polk9
Established Member
Posts: 6
Joined: Fri Oct 18, 2019 1:48 pm
Contact:

Lin-vst problems (version mismatch)

Postby polk9 » Mon Nov 04, 2019 1:51 am

Hi all !

I have since one week some problems with LinVST.

When Harrison and Bitwig 3.0.3 try to load vst, i get a GUI message with this title :

Code: Select all

lin-vst server/vst not found or LinVst version mismatch


- I tried to erase all LinVST files in /usr/bin, re-installed LinVST with .deb via github : same issue (it's 2.7)
- I tried an upgrade to Wine 4.5 staging, the upgrade removes Bitwig Studio and other softwares like vlc, kdenlive, etc... : same issue anyway
- so i went back to wine 4.17 via Timeshift : also same issue.

I'm running Ubuntu Studio 19.10, freshly upgraded from 19.04. Was working very well in the firsts days.
Okay I understood, keeping native Linux VST is better :p but i'm really annoyed about this because i can't load old projects :/ Does someone have any idea about this problem ?

Thanks in advance for your answers !

ubuntuuser
Established Member
Posts: 255
Joined: Mon Jan 02, 2017 9:46 am

Re: Lin-vst problems (version mismatch)

Postby ubuntuuser » Mon Nov 04, 2019 5:11 am

If you have an older version LinVst .so file hanging around somewhere in your DAW search paths, then that can trigger the version mismatch error.

If the lin-vst-serverxxxx files havn't been installed to /usr/bin then that can trigger the version mismatch error.

Maybe try to get the DAW search paths from the DAW and then use the newer version linvst.so with linvstconvert on the DAW search paths, and that will overwrite any older Linvst .so files that are maybe hanging around.

Also do a ls /usr/bin/lin-vst* to see if the lin-vst-serverxxxx files are in /usr bin.

Also maybe manually try to overwrite the /usr/bin/lin-vst-serverxxxx files with the newer version lin-vst-serverxxxx files.

User avatar
polk9
Established Member
Posts: 6
Joined: Fri Oct 18, 2019 1:48 pm
Contact:

Re: Lin-vst problems (version mismatch)

Postby polk9 » Mon Nov 04, 2019 1:05 pm

If you have an older version LinVst .so file hanging around somewhere in your DAW search paths, then that can trigger the version mismatch error.


I really think that I never changed LinVst version as i'm not since a lot of time on Gnu/linux (2 monthes). I also erased all .so files and reconverted .dll via linvstconvert : nothing new

If the lin-vst-serverxxxx files havn't been installed to /usr/bin then that can trigger the version mismatch error.


there are here :

Code: Select all

ls /usr/bin/lin-vst*
/usr/bin/lin-vst-servertrack32.exe     /usr/bin/lin-vst-servertrack.exe
/usr/bin/lin-vst-servertrack32.exe.so  /usr/bin/lin-vst-servertrack.exe.so


Also maybe manually try to overwrite the /usr/bin/lin-vst-serverxxxx files with the newer version lin-vst-serverxxxx files.


I did it via the .deb and after did it again manually, nothing new...

ubuntuuser
Established Member
Posts: 255
Joined: Mon Jan 02, 2017 9:46 am

Re: Lin-vst problems (version mismatch)

Postby ubuntuuser » Tue Nov 05, 2019 3:59 am

If there is a .so file without a matching dll file, then that can trigger the error.

for instance, testvst.so is in the DAW search path but there is no testvst.dll


Return to “Running non-linux software”

Who is online

Users browsing this forum: Loki Harfagr and 7 guests