Page 1 of 13

Airwave VST bridge

Posted: Tue Apr 14, 2015 11:47 am
by phant0m
Hi!

I'm glad to present here my little project: the Airwave VST bridge. This is a WINE-based VST bridge for using Windows audio plugins with Linux hosts.
For a long time, I didn't publish it anywhere except the Bitwig's subforum on the KVR. A few days ago I've made the first major release and from my point of view it's relatively stable and feature-rich now. I think this forum is a more suitable place for such project, so I'll try to keep this topic up to date.

The pre-built binaries for Arch Linux and Ubuntu 14.04 could be found here. Besides that, the Arch Linux users can build the latest development version from the AUR.

For additional information, please read the project page on the GitHub or just ask here.

I hope you'll like it and have fun! :D

Re: Airwave VST bridge

Posted: Tue Apr 14, 2015 9:43 pm
by sysrqer
Looking forward to giving this update a try, I was using the previous version very happily. Once I have time to update everything I'll give it a try. Thanks a lot for all the work!

Re: Airwave VST bridge

Posted: Tue Apr 14, 2015 10:20 pm
by Vrangor
You know what? I`ve spent whole day trying to compile it, just to find out, that it doesn`t work on Ardour.
After scan for new plugins i get:
[ERROR]: Could not open existing LXVST plugin: /usr/lib/vst/BootEQmkII.so: wrong ELF class: ELFCLASS32
[WARNING]: Cannot get LinuxVST information from /usr/lib/vst/BootEQmkII.so: load failed.

I work on 64 bit linux, maybe this is the problem?
Ardour and wine-rt from KXStudio.

Re: Airwave VST bridge

Posted: Tue Apr 14, 2015 10:56 pm
by sysrqer
Have you tried any other plugins Vrangor? Those particular ones are problematic, they work for me in the old version of Airwave but they're not reliable, and the project page says they don't work.

Re: Airwave VST bridge

Posted: Wed Apr 15, 2015 8:51 am
by phant0m
Vrangor wrote:You know what? I`ve spent whole day trying to compile it, just to find out, that it doesn`t work on Ardour.
After scan for new plugins i get:
[ERROR]: Could not open existing LXVST plugin: /usr/lib/vst/BootEQmkII.so: wrong ELF class: ELFCLASS32
[WARNING]: Cannot get LinuxVST information from /usr/lib/vst/BootEQmkII.so: load failed.

I work on 64 bit linux, maybe this is the problem?
Ardour and wine-rt from KXStudio.

The Variety of Sound plugins are known not to work with Airwave, but I didn't test them myself. Will look them closely, thanks for the feedback. According to your issue, falkTX is right: you cannot run 32-bit plugins on a 64-bit host. This works in the Bitwig Studio, but it has its own bridge in the chain.

Re: Airwave VST bridge

Posted: Wed Apr 15, 2015 11:32 am
by phant0m
I've just tested the BootEQ mkII in the Cocos Reaper and it works. It seems that this is an Airwave issue, I will investigate it tonight.

Re: Airwave VST bridge

Posted: Wed Apr 15, 2015 5:20 pm
by phant0m
The crashing of the Variety of Sound plugins is fixed in 1.0.2. New binary packages are available.

Re: Airwave VST bridge

Posted: Wed Apr 15, 2015 11:29 pm
by Vrangor
Thank You all for answers!
So this all means, that i`m unable to run VoS plugins in Ardour using Airwave on my system as they are 32bit only, as well as for example Kjaerhus, and many others?

Re: Airwave VST bridge

Posted: Thu Apr 16, 2015 6:25 am
by bazsound
Does this require ubuntu 14.04?

i aks because i notice that qt5 is in the required dependancies . qt5 is in 12.04 but i had issues installing obd autodoctor on another machine that stated qt5 and i had to hack in a new version of qt5 to get that installed and my laptop mysteriously broke LXDE and now only loads openbox.

seems like i may not be able to avoid 14.04 any longer which is a shame because 12.04 has been solid for a while now.

Re: Airwave VST bridge

Posted: Thu Apr 16, 2015 8:35 am
by phant0m
Vrangor, I'm planning to add 64->32 bridging functionality to the Airwave. If everything goes smoothly, it'll be in the next minor release.

Re: Airwave VST bridge

Posted: Thu Apr 16, 2015 8:45 am
by phant0m
bazsound wrote:Does this require ubuntu 14.04?

The Airwave manager application requires the Qt5 library for GUI, but this is just the graphical configurator. Technically, you could use only the bridge itself and write the configuration file manually (JSON). Practically, I wouldn't recommend this, as you should know the configuration format and conventions, which can be changed anytime.
I haven't much knowledge of the Ubuntu peculiarities, but if you could install somehow the Qt5 on the 12.04, then all should be fine. I do the packaging on the 14.04 if it makes sense.

Re: Airwave VST bridge

Posted: Thu Apr 16, 2015 11:05 pm
by Vrangor
Vrangor, I'm planning to add 64->32 bridging functionality to the Airwave. If everything goes smoothly, it'll be in the next minor release.


I was just about to ask if it`s planned :) There are a lot of great 32b plugins, that rather won`t be re-released as 64. In fact every vst I use is 32 only, maybe except Voxengo ones, which I think are available as 64. Anyway thanks for info and for great work, can`t wait to test it!
By the way, I didn`t know I can get Airwave binaries. I would test it earlier instead trying to compile it, which is in fact a hell for me:)
Cheers!

Re: Airwave VST bridge

Posted: Fri Apr 17, 2015 8:35 am
by phant0m
Personally, I also use mostly the 32-bit plugins. AFAIK, wine is more stable in 32-bit mode. Also, there is no any significant benefits from 64-bit plugins (perhaps with an exception of the NI Kontakt) as Airwave launches separate process for each plugin anyway (a process may get 4 GB of memory).

Re: Airwave VST bridge

Posted: Fri Apr 17, 2015 5:58 pm
by phant0m
The 64-bit to 32-bit bridging is implemented in a new version 1.1.0. Now you can use 32-bit plugins on a 64-bit host. My tests are passed successfully, but this is very experimental release. As usual, there are binary packages for Ubuntu and Arch Linux on the releases page.

Re: Airwave VST bridge

Posted: Sat Apr 18, 2015 6:47 pm
by Vrangor
Noob`s problems :oops:
Required wine1.7, installed wine-rt1.7.xx
Also tried to run manually extracted airwave-manager:

Code: Select all

airwave-manager: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by airwave-manager)

and

Code: Select all

~$ strings /usr/lib/x86_64-linux-gnu/libstdc++.so.6 | grep GLIBCXX
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
GLIBCXX_3.4.14
GLIBCXX_3.4.15
GLIBCXX_3.4.16
GLIBCXX_3.4.17
GLIBCXX_3.4.18
GLIBCXX_3.4.19
GLIBCXX_DEBUG_MESSAGE_LENGTH

Mint LMDE up to date+KXStudio
Help?