Airwave VST bridge

Discuss running non-Linux applications and plugins on Linux, for example via wine

Moderators: khz, MattKingUSA

Vrangor
Established Member
Posts: 37
Joined: Fri Apr 25, 2014 11:47 pm

Re: Airwave VST bridge

Postby Vrangor » Sat Apr 18, 2015 6:47 pm

Noob`s problems :oops:
Required wine1.7, installed wine-rt1.7.xx
Also tried to run manually extracted airwave-manager:

Code: Select all

airwave-manager: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by airwave-manager)

and

Code: Select all

~$ strings /usr/lib/x86_64-linux-gnu/libstdc++.so.6 | grep GLIBCXX
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
GLIBCXX_3.4.14
GLIBCXX_3.4.15
GLIBCXX_3.4.16
GLIBCXX_3.4.17
GLIBCXX_3.4.18
GLIBCXX_3.4.19
GLIBCXX_DEBUG_MESSAGE_LENGTH

Mint LMDE up to date+KXStudio
Help?

User avatar
phant0m
Established Member
Posts: 49
Joined: Tue Apr 14, 2015 11:03 am
Contact:

Re: Airwave VST bridge

Postby phant0m » Sat Apr 18, 2015 7:40 pm

The binaries from my package are linked with libstdc++.so.6.0.20 and it looks like the latest version you have is 6.0.19. Can you update the libstdc++6 package? On Ubuntu this could be achieved by the following command

Code: Select all

sudo apt-get install libstdc++6

I will try to use an older compiler and change the wine dependency in my package.

User avatar
phant0m
Established Member
Posts: 49
Joined: Tue Apr 14, 2015 11:03 am
Contact:

Re: Airwave VST bridge

Postby phant0m » Sat Apr 18, 2015 8:02 pm

What package have you extracted manually? I guess it was the Arch Linux package? The binaries from the Ubuntu package linked with correct libstdc++. I will update it soon with less strict wine dependency.

User avatar
phant0m
Established Member
Posts: 49
Joined: Tue Apr 14, 2015 11:03 am
Contact:

Re: Airwave VST bridge

Postby phant0m » Sat Apr 18, 2015 8:06 pm

Vrangor, try to install the updated package: https://github.com/phantom-code/airwave ... _amd64.deb
I hope that the issue with incorrect wine dependency should be solved.

Vrangor
Established Member
Posts: 37
Joined: Fri Apr 25, 2014 11:47 pm

Re: Airwave VST bridge

Postby Vrangor » Sat Apr 18, 2015 11:13 pm

Previously I extracted the .deb one.
Now I have libqt5core5a: dependency cannot be resolved.
I have libqt5core.so.5.1.1, tried to make link as libqt5core.so.5a, but it didn`t help :)
My libstdc++ is 6.0.18, no update as far now. I have Mint LMDE.

User avatar
phant0m
Established Member
Posts: 49
Joined: Tue Apr 14, 2015 11:03 am
Contact:

Re: Airwave VST bridge

Postby phant0m » Sun Apr 19, 2015 8:07 am

I have downloaded the Linux Mint livecd from here, started it and installed the deb package without any issues. Will try to find your issue anyway.

UPDATE:
Here are the packages installed on the Mint livecd:

Code: Select all

$ dpkg -s libqt5core5a
Package: libqt5core5a
Status: install ok installed
Priority: optional
Section: libs
Installed-Size: 5118
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: amd64
Multi-Arch: same
Source: qtbase-opensource-src
Version: 5.2.1+dfsg-1ubuntu14.2
Replaces: libqt5core5 (<< 5.2.0+dfsg~)
Provides: qtbase-abi-5-2-1
Depends: libc6 (>= 2.15), libgcc1 (>= 1:4.1.1), libglib2.0-0 (>= 2.22.0), libicu52 (>= 52~m1-1~), libstdc++6 (>= 4.1.1), zlib1g (>= 1:1.1.4)
Pre-Depends: dpkg (>= 1.15.6~), multiarch-support
Suggests: libthai0
Breaks: libqt5core5 (<< 5.2.0+dfsg~)
Description: Qt 5 core module
 Qt is a cross-platform C++ application framework. Qt's primary feature
 is its rich set of widgets that provide standard GUI functionality.
 .
 The QtCore module contains core non-GUI functionality.
Homepage: http://qt-project.org/
Original-Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>

Code: Select all

$ dpkg -s libqt5core5a
Package: libqt5core5a
Status: install ok installed
Priority: optional
Section: libs
Installed-Size: 5118
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: amd64
Multi-Arch: same
Source: qtbase-opensource-src
Version: 5.2.1+dfsg-1ubuntu14.2
Replaces: libqt5core5 (<< 5.2.0+dfsg~)
Provides: qtbase-abi-5-2-1
Depends: libc6 (>= 2.15), libgcc1 (>= 1:4.1.1), libglib2.0-0 (>= 2.22.0), libicu52 (>= 52~m1-1~), libstdc++6 (>= 4.1.1), zlib1g (>= 1:1.1.4)
Pre-Depends: dpkg (>= 1.15.6~), multiarch-support
Suggests: libthai0
Breaks: libqt5core5 (<< 5.2.0+dfsg~)
Description: Qt 5 core module
 Qt is a cross-platform C++ application framework. Qt's primary feature
 is its rich set of widgets that provide standard GUI functionality.
 .
 The QtCore module contains core non-GUI functionality.
Homepage: http://qt-project.org/
Original-Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>


UPDATE2:
What release of the Linux Mint are you using?

Code: Select all

$ egrep -w 'RELEASE|CODENAME' /etc/linuxmint/info
RELEASE=17.1
CODENAME=rebecca

Vrangor
Established Member
Posts: 37
Joined: Fri Apr 25, 2014 11:47 pm

Re: Airwave VST bridge

Postby Vrangor » Sun Apr 19, 2015 8:02 pm

It`s MINT LMDE, which means Linux Mint Debian Edition, it is not Ubuntu based distro, but Debian testing.
http://www.linuxmint.com/download_lmde.php

User avatar
phant0m
Established Member
Posts: 49
Joined: Tue Apr 14, 2015 11:03 am
Contact:

Re: Airwave VST bridge

Postby phant0m » Mon Apr 20, 2015 9:52 pm

New patch version update (1.1.1):

FIXED Regression: plugin's parameters are not exported to the host correctly

User avatar
phant0m
Established Member
Posts: 49
Joined: Tue Apr 14, 2015 11:03 am
Contact:

Re: Airwave VST bridge

Postby phant0m » Mon Apr 20, 2015 10:04 pm

Vrangor, I have successfully installed Airwave using the LMDE (Cinnamon) livecd (screenshot).
Do you still have your issue? Can you try to install the latest package?

Vrangor
Established Member
Posts: 37
Joined: Fri Apr 25, 2014 11:47 pm

Re: Airwave VST bridge

Postby Vrangor » Tue Apr 21, 2015 8:18 pm

phant0m, thank You very much for Your great work and feedback! I still have libqt5core5a dep problem, BUT it`s because I have LMDE 1, according to Mint devs upgrade to LMDE 2 is in progress, however if it doesn`t show until end of the week, I`ll install fresh LMDE 2 + Airwave, and give You report from testing all my VSTs with it.
Thx again, cheers!

User avatar
phant0m
Established Member
Posts: 49
Joined: Tue Apr 14, 2015 11:03 am
Contact:

Re: Airwave VST bridge

Postby phant0m » Tue Apr 21, 2015 8:34 pm

Vrangor, you're welcome! If you will encounter any issues I'll be glad to help.

higltypig
Established Member
Posts: 21
Joined: Mon Apr 27, 2015 9:04 pm

Re: Airwave VST bridge

Postby higltypig » Mon Apr 27, 2015 9:09 pm

I'm trying very hard to get this to work.

I seem to have some issue with where my vst plugin folder is. If it's set to /usr/lxvst then Ardour sees the plugs but airwave manager says the links are all corrupt - wondering if it's because it doesn't have the rights to access that folder?

I've set my folder to ~/.vst but it's still not working and now ardour doesn't see my vsts.

Any ideas? - airwave manager just says each plugins link is corrupt. oddly Audacity sees and goes through my native Vsts but then they aren't in the plugin list..

Reaper via wine works perfectly but I'd like to get this working.....

User avatar
phant0m
Established Member
Posts: 49
Joined: Tue Apr 14, 2015 11:03 am
Contact:

Re: Airwave VST bridge

Postby phant0m » Mon Apr 27, 2015 9:28 pm

The message "VST plugin is corrupted." is shown when Airwave plugin binary (airwave-plugin.so) isn't found. Where did you install the Airwave? You should set the "Binaries location" (in the settings dialog) to the path, where the Airwave binaries are located. See this screencast as example: https://dl.dropboxusercontent.com/u/335 ... cation.ogv

User avatar
phant0m
Established Member
Posts: 49
Joined: Tue Apr 14, 2015 11:03 am
Contact:

Re: Airwave VST bridge

Postby phant0m » Mon Apr 27, 2015 9:49 pm

Well, I feel that I've misunderstood you. It seems that you getting the message "Link <filename> is corrupted" in the logs. First of all, the "link location" directory should be writable by the Airwave. Second, you shouldn't move manually any .so files, created by the airwave manager. The link's .so path is used at the runtime as a key to finding the corresponding VST dll file. If link's path isn't found in the configuration file ${HOME}/.config/airwave.conf, then the "Link is corrupted" message is displayed. I hope it helps somehow. If not, feel free to ask. Also, the logs could be useful for me.

User avatar
phant0m
Established Member
Posts: 49
Joined: Tue Apr 14, 2015 11:03 am
Contact:

Re: Airwave VST bridge

Postby phant0m » Mon Apr 27, 2015 10:22 pm

I've recorded another screencast which shows an example usage of the Airwave and Bitwig Studio: https://dl.dropboxusercontent.com/u/335 ... -usage.ogv


Return to “Running non-linux software”

Who is online

Users browsing this forum: No registered users and 1 guest