Build failure (2) - closed

MusE is a MIDI/Audio sequencer with recording and editing capabilities, aiming to be a complete multitrack virtual studio for Linux. http://muse-sequencer.org/

Moderators: khz, MattKingUSA, spamatica

AndyF
Established Member
Posts: 8
Joined: Sat Mar 30, 2019 9:05 am

Build failure (2) - closed

Postby AndyF » Sun Jun 02, 2019 9:17 am

Latest gitpull throws an error while building:

Code: Select all

Create build dir
-- The C compiler identification is GNU 7.4.0
-- The CXX compiler identification is GNU 7.4.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.29.1")
 vst header path: /home/andy/muse/muse3/vestige
-- Found Git: /usr/bin/git (found version "2.17.1")
Unix (probably linux) found
-- Looking for pthread.h
-- Looking for pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE 
-- Looking for ladspa.h
-- Looking for ladspa.h - found
-- Checking for module 'sndfile>=1.0.0'
--   Found sndfile, version 1.0.28
-- Checking for module 'samplerate>=0.1.0'
--   Found samplerate, version 0.1.9
-- Checking for module 'jack>=0.103'
--   Found jack, version 1.9.12
-- Looking for exp10
-- Looking for exp10 - found
-- Looking for exp10f
-- Looking for exp10f - found
-- Looking for exp10l
-- Looking for exp10l - found
-- Checking for module 'alsa>=0.9.0'
--   Found alsa, version 1.1.3
-- Checking for module 'lash-1.0>=0.2'
--   Found lash-1.0, version 0.6.0
-- Checking for module 'lrdf>=0.5'
--   No package 'lrdf' found
-- Checking for module 'rtaudio>=4.0'
--   Found rtaudio, version 5.0.0
-- Checking for module 'liblo>=0.23'
--   Found liblo, version 0.29
-- Checking for module 'dssi>=0.9.0'
--   Found dssi, version 1.1.1
Native VST support enabled
-- Checking for module 'lilv-0>=0.22.0'
--   No package 'lilv-0' found
-- Checking for module 'sord-0>=0.14.0'
--   No package 'sord-0' found
-- Checking for module 'lv2>=1.12.0'
--   Found lv2, version 1.14.0
-- Checking for module 'fluidsynth>=0.9.0'
--   Found fluidsynth, version 1.1.9
-- Checking for module 'libinstpatch-1.0'
--   Found libinstpatch-1.0, version 1.0.0


** WARNING: lrdf (>= 0.5) was enabled, but development files were not found.
** WARNING: LV2 support was chosen, but development files were not found or too old:
   Requires lv2 >= 1.12.0, lilv-0 >= 0.22.0, sord-0 >= 0.14.0
   Hint: Last resort: Try cmake option ENABLE_LV2_SUPPLIED to build supplied internal versions instead.


The following components will be built:
-----------------------------------------------
   ALSA support
   RTAudio support
   Lash support
   OSC (Liblo) support
   DSSI support
   Native VST support
   Fluidsynth support
   Instpatch support

The following components WILL NOT be built:
-----------------------------------------------
   Lrdf support
   Python support
   LV2 support
   Experimental features

 Internal modules will be built as shared components.
 Build type: release

CMake Error at muse/CMakeLists.txt:391 (install):
  install TARGETS given target "lv2host_module" which does not exist in this
  directory.


-- Configuring incomplete, errors occurred!
See also "/home/andy/muse/muse3/build/CMakeFiles/CMakeOutput.log".
See also "/home/andy/muse/muse3/build/CMakeFiles/CMakeError.log".


Version from 2019-04-16 could be compiled and works as expected.
I deleted whole git directory and started git clone/compiling again - same result.

I'm on linux-mint 19.1. My lv2-dev package is version 1.14.0

How can I fix this?

regards, Andy
Last edited by AndyF on Sun Jun 02, 2019 10:28 am, edited 1 time in total.

Musicteacher
Established Member
Posts: 167
Joined: Mon Nov 13, 2017 5:54 am

Re: Build failure (2)

Postby Musicteacher » Sun Jun 02, 2019 9:26 am

If I read the cmake-output correctly, you are missing:

lilv-0 >= 0.22.0, sord-0 >= 0.14.0

Install the dev-packages for those and reconfigure. Or use the cmake-variable to use the builtin-version of lv2-support.

Regards,
Andreas

AndyF
Established Member
Posts: 8
Joined: Sat Mar 30, 2019 9:05 am

Re: Build failure (2)

Postby AndyF » Sun Jun 02, 2019 9:33 am

Hi Andreas,

do you know a good place or repo to get this packages?
Are there any disadvantages to use built-in support?

EDIT: Installing "liblilv-dev" did the trick. My mistake was only to install liblilv (without dev).

Regards, Andy

Tim E. Real
Established Member
Posts: 226
Joined: Sat Sep 15, 2012 12:36 am

Re: Build failure (2) - closed

Postby Tim E. Real » Sun Jun 02, 2019 5:06 pm

Hi just a quick note: We no longer 'fall back' to the supplied internal LV2 libraries
if the LV2 system libraries are not found. If desired, the internal LV2 libraries
must now be explicitly enabled with the cmake flag ENABLE_LV2_SUPPLIED,
as shown in the printout.

One of the reasons we supply internal LV2 libraries is that a total of three LV2 libraries are required
and sometimes people don't realize that, and they only install the one LV2 library for example.
We knew that kind of thing would happen so we supplied internal versions.

But our internal LV2 versions may cause some headaches for certain packagers, so we no longer build them by default.

Tim.

folderol
Established Member
Posts: 909
Joined: Mon Sep 28, 2015 8:06 pm
Location: Here, of course!
Contact:

Re: Build failure (2) - closed

Postby folderol » Sun Jun 02, 2019 5:37 pm

Tim E. Real wrote:One of the reasons we supply internal LV2 libraries is that a total of three LV2 libraries are required
Tim.

Lost for words :shock:


Return to “MusE Sequencer”

Who is online

Users browsing this forum: No registered users and 2 guests