linVST and 32-bit software

All your LV2 and LADSPA goodness and more.

Moderators: khz, MattKingUSA

jonetsu
Established Member
Posts: 1490
Joined: Sat Jun 11, 2016 12:05 am

linVST and 32-bit software

Postby jonetsu » Thu Apr 19, 2018 8:34 pm

So far the Voxengo plugins I tried and used with linVST works very well if we put aside the inter-process communi9cation which is an add-on feature to the core functionality. And so far all these plugins were 64-bit. Voxengo also have a VST convolution processor software which is 32-bit. I quickly tried it, and no luck loading that one. It's a software that dates from sometime, not at all in the current UI design, more like a traditional Windows app, and the installation directory bears the name ../Avid/Voxengo/.

Is 32-bit software to be executed differently ?

UPDATE: Looks like there's a need for a lin-vst-server32.exe which I do not have at the moment in /usr/bin/ The make, make install I did not produce such a binary. I'll look into that.

ubuntuuser
Established Member
Posts: 273
Joined: Mon Jan 02, 2017 9:46 am

Re: linVST and 32-bit software

Postby ubuntuuser » Fri Apr 20, 2018 4:18 am

Makefile-embed-6432 is for 64/32 bits.

How to make the 64/32 bit version is at the end of the github readme.

Not everyone has the mutilibs installed so the default LinVst makefile is 64 bit only.

32 bit vst's running under the 64bit LinVst versions need a distros multiarch to be enabled (sudo apt-get install gcc-multilib g++-multilib for Ubuntu/Debian).


Return to “Plugins, Effects and Instruments”

Who is online

Users browsing this forum: No registered users and 2 guests