Carla crashes on .dll VST plugin load

Official support for the KXStudio Linux distribution and applications.
More info at http://kxstudio.linuxaudio.org/

Moderators: falkTX, khz, MattKingUSA

Arneb
Established Member
Posts: 4
Joined: Fri Nov 23, 2018 8:52 pm

Carla crashes on .dll VST plugin load

Postby Arneb » Fri Nov 23, 2018 9:10 pm

Hi everyone,

I'm trying to get a fairly old .dll VST plugin to run in Carla. Carla finds the plugin fine, but crashes on me when I try to actually add it. Setup is Cadence and Carla running on Ubuntu 18.04. Plugin in question is the demo version of Syntheway's Harmodion; help from that side is probably not forthcoming as the docs were written before KXStudio existed. Carla version is 1.9.11 (2.0-RC1).

I could not find any Carla logs. There's a core dump, but its usefulness is limited by a lack of symbol tables in JACK and Carla; nonetheless I'm including the gdb backtrace:

Code: Select all

Reading symbols from /usr/bin/python3.6...(no debugging symbols found)...done.
warning: core file may not match specified executable file.
[New LWP 16838]
[New LWP 16837]
[New LWP 16829]
[New LWP 16830]
[New LWP 16831]
[New LWP 16884]
[New LWP 16834]
[New LWP 16825]
[New LWP 16841]
[New LWP 16832]
[New LWP 16833]
[New LWP 16839]
[New LWP 16835]
[New LWP 16836]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `/usr/bin/python3 /usr/share/carla/carla --with-appname=/usr/bin/carla --with-li'.
Program terminated with signal SIGABRT, Aborted.
#0  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:51
51   ../sysdeps/unix/sysv/linux/raise.c: No such file or directory.
[Current thread is 1 (Thread 0x7f87cf187700 (LWP 16838))]
(gdb) bt full
#0  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:51
        set = {__val = {4096, 140220884323280, 140728019967504, 140222194153023, 140226314731520, 140220884323280, 140220884323381, 140220884323280, 140220884323280, 140220884323423, 140220884323580,
            140220884323280, 140220884323580, 0, 0, 0}}
        pid = <optimized out>
        tid = <optimized out>
        ret = <optimized out>
#1  0x00007f88060df801 in __GI_abort () at abort.c:79
        save_stage = 1
        act = {__sigaction_handler = {sa_handler = 0x7f87b8000d10, sa_sigaction = 0x7f87b8000d10}, sa_mask = {__val = {0, 0, 0, 0, 0, 140221271796040, 0, 140221271795872, 140222195409360, 21474836480,
              140222195394520, 0, 1802936832128629248, 140222195379476, 0, 140222195394520}}, sa_flags = -385036496, sa_restorer = 0x7f87e90cd80a}
        sigs = {__val = {32, 0 <repeats 15 times>}}
        __cnt = <optimized out>
        __set = <optimized out>
        __cnt = <optimized out>
        __set = <optimized out>
#2  0x00007f88060cf39a in __assert_fail_base (fmt=0x7f88062567d8 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=assertion@entry=0x7f87e90cd80a "port_index < fPortMax",
    file=file@entry=0x7f87e90ccf30 "../common/JackGraphManager.cpp", line=line@entry=44, function=function@entry=0x7f87e90cd8c0 "void Jack::JackGraphManager::AssertPort(jack_port_id_t)") at assert.c:92
        str = 0x7f87b8000d10 ""
        total = 4096
#3  0x00007f88060cf412 in __GI___assert_fail (assertion=0x7f87e90cd80a "port_index < fPortMax", file=0x7f87e90ccf30 "../common/JackGraphManager.cpp", line=44,
    function=0x7f87e90cd8c0 "void Jack::JackGraphManager::AssertPort(jack_port_id_t)") at assert.c:101
No locals.
#4  0x00007f87e90939ff in ?? () from /usr/lib/x86_64-linux-gnu/libjack.so.0
No symbol table info available.
#5  0x00007f87e909f20d in ?? () from /usr/lib/x86_64-linux-gnu/libjack.so.0
No symbol table info available.
#6  0x00007f87e909432e in jack_port_name () from /usr/lib/x86_64-linux-gnu/libjack.so.0
No symbol table info available.
#7  0x00007f87eebb4510 in ?? () from /usr/lib/carla/libcarla_standalone2.so
No symbol table info available.
#8  0x00007f87eeb6e4a5 in ?? () from /usr/lib/carla/libcarla_standalone2.so
No symbol table info available.
#9  0x00007f8805e876db in start_thread (arg=0x7f87cf187700) at pthread_create.c:463
        pd = 0x7f87cf187700
        now = <optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {140221271799552, 2151827052099723183, 140221271797696, 0, 45913408, 140728019967504, -2102251400502517841, -2104068754932572241},
              mask_was_saved = 0}}, priv = {pad = {0x0, 0x0, 0x0, 0x0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
        not_first_call = <optimized out>
#10 0x00007f88061c088f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95
No locals.


From what little information we have it looks related to JACK's port range. Is this a bug in Carla, a bug in JACK, or an issue with the plugin?

Return to “KXStudio Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest