Carla won't open Plugin GUI

Unofficial support for the KXStudio Linux distribution and applications.
More info at http://kxstudio.linuxaudio.org/

Moderators: khz, MattKingUSA

turboulli
Posts: 1
Joined: Wed Nov 14, 2018 1:24 pm

Carla won't open Plugin GUI

Postby turboulli » Thu Nov 15, 2018 3:58 pm

Hello guys,

I am using carla-git with LinVst, running on Arch 64bit. Loading my win64 plugins (GSI VB3 and NI Kontakt) into carla works perfectly well, it produces sound and I am able to map the midi stuff. But when I am opening the GUI nothing happens and the carla log gives following ouput:

GSI VB3:

Code: Select all

Plugin refused to open its own UI
002a:fixme:x11drv:X11DRV_DestroyNotify window 0x2004e/2a00001 destroyed from the outside


NI Kontakt:

Code: Select all

Plugin refused to open its own UI
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  18 (X_ChangeProperty)
  Resource id in failed request:  0x2c00005
  Serial number of failed request:  179
  Current serial number in output stream:  204


Altough the output is slightly different it is probably caused by the same problem.
I think xorg or wine could cause these problem but in ardour the GUI works perfectly fine, so my guess is that it is caused by carla.

Has anybody an idea what could cause this problem?

eamner
Posts: 1
Joined: Mon Sep 04, 2017 11:17 pm

Re: Carla won't open Plugin GUI

Postby eamner » Fri Dec 28, 2018 8:40 pm

Hello

I'm having the same issue. Were you able to fix it?
I converted all my dlls to .so with LinVst (previously I was unable to open any dll in Carla). I have tested and most of them sound great but none will show the GUI when clicking on 'Show Custom GUI'. This makes it difficult to work with some plugin features.


Return to “KXStudio Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest