Enable S/PDIF PCM with JACK Audio by adding IEC958 in KMix

Unofficial support for the KXStudio Linux distribution and applications.
More info at http://kxstudio.linuxaudio.org/

Moderators: khz, MattKingUSA

tbritton
Established Member
Posts: 33
Joined: Sun Jan 29, 2012 4:22 am

Re: Enable S/PDIF PCM with JACK Audio by adding IEC958 in KM

Postby tbritton » Thu May 02, 2013 8:16 am

It was fate.

Terry

danboid wrote:I've only just seen this thread and its quite sad that you say you spent 3 hours trying to enable SPDIF because a few months before you started this thread I had already posted a keyword-laden guide to this same process on these forums:

http://www.linuxmusicians.com/viewtopic ... 19&t=10271

So I can only presume you didn't search these forums for SPDIF before you created this thread? Oh well! :/

zth
Established Member
Posts: 94
Joined: Mon Jan 16, 2012 9:06 pm

Re: Enable S/PDIF PCM with JACK Audio by adding IEC958 in KM

Postby zth » Thu May 02, 2013 3:29 pm

I'm having issues with this.
I own a Juli@ XTe PCIe card, and I'm trying to use the S/PDIF in to record my guitar, which is connected to the S/PDIF in via its FX-unit. This all worked fine with a Lexicon Omega USB, as that did the mixing itself.

I just can't get it to work. I followed this guide, but I have no "PCM Input Source". Here's a couple of informational pictures from both JACK and QASMixer:

Image
Here's my Cadence settings. I note that there's an additional entry for the hw:Juli,1 but that effectively doesn't work using, at least not by itself like that.

Image
My alsamixer.

Image
My QASMixer. Super-kudos to anyone that can explain to me what the different controls mean/do btw :D

I'm in desperate need of help here, I just simply _can't_ figure out how to do this. Thanks a ton in advance!

ToddMWorth
Established Member
Posts: 225
Joined: Tue Oct 23, 2012 3:59 am

Re: Enable S/PDIF PCM with JACK Audio by adding IEC958 in KM

Postby ToddMWorth » Fri May 03, 2013 12:24 am

It's probably a good thing he didn't use that guide, because that's for a different kind of card that works strangely. Every single SPDIF IO I've ever enabled in linux (dozens and dozens) has not required your process; only to unmute the digital outs as explained in this thread.... Still, it's good that the two threads are linked now!


Return to “KXStudio Discussion”

Who is online

Users browsing this forum: No registered users and 6 guests