[Abandoned] Can't take ownership of exFAT HDD's

What other apps and distros do you use to round out your studio?

Moderators: khz, MattKingUSA

User avatar
bluebell
Established Member
Posts: 1042
Joined: Sat Sep 15, 2012 11:44 am
Location: Saarland & Frankfurt, Germany

Re: Can't take ownership of HDD's as root

Postby bluebell » Mon Feb 11, 2019 3:09 pm

Death wrote:
merlyn wrote:I'm not sure what you mean by 'take'. If you can write a file then all would seem to be well.


Take ownership I meant. My backup program has been stalling and returning errors about permissions ever since this issue appeared. I cannot do any backups right now because of this. I've checked the drive for errors and it's apparently ok. I've reformatted it too. Something happened around the time I used Photorec and I think it's changed something in my config somewhere. This is why I want to take ownership of these drives so I can see if my backups work again..


Many, many questions left. What filesystem is on the disk? How is it mounted? Shall the backup program run as root and if not, was it accidently run as root?

Death
Established Member
Posts: 147
Joined: Sun Oct 11, 2015 1:43 pm

Re: Can't take ownership of HDD's as root

Postby Death » Mon Feb 11, 2019 3:26 pm

bluebell wrote:
Death wrote:
merlyn wrote:I'm not sure what you mean by 'take'. If you can write a file then all would seem to be well.


Take ownership I meant. My backup program has been stalling and returning errors about permissions ever since this issue appeared. I cannot do any backups right now because of this. I've checked the drive for errors and it's apparently ok. I've reformatted it too. Something happened around the time I used Photorec and I think it's changed something in my config somewhere. This is why I want to take ownership of these drives so I can see if my backups work again..


Many, many questions left. What filesystem is on the disk? How is it mounted? Shall the backup program run as root and if not, was it accidently run as root?


Ok. So, I have my system disk which is an ext4 SSD. I backup the Home folder from there to an internal storage drive which is an ext4 HDD. I also have an external storage drive which is exfat formatted. I then backup these two storage drives to an external Backup HDD which is normally exfat formatted and it has worked fine like this months. I've also tried formatting that external backup drive to ext4 but it makes no difference. The program I use is LuckyBackup (Rsync front end) with 3 backup tasks:
1. Home folder to internal storage drive.
2. Internal storage drive to external backup drive.
3. External storage drive to external backup drive.

"How are they mounted?" Sorry but I'm not sure what you mean by that. Could you elaborate please?

LuckyBackup does not run as root as far as I know (no password is required to launch it). Although it does have an option called 'Attempt super-user activities' which has always been enabled for all of my backup tasks with no apparent issues. I've tried disabling that option too but it makes no difference. I've also tried purging LuckyBackup and deleting all files I could find for it, then reinstalling it and recreating my backup tasks from scratch. The way I had it all setup was working great the whole time until I ran Photorec the other day. Now, my backups just stall a small part of the way through and the backup drive goes into standby. I've never had this before :shock: Cheers.

Edit: Btw, LuckyBackup has an option called 'Destination is FAT/NTFS' which I enable.

jonetsu
Established Member
Posts: 1400
Joined: Sat Jun 11, 2016 12:05 am

Re: Can't take ownership of HDD's as root

Postby jonetsu » Mon Feb 11, 2019 3:47 pm

Death wrote:
merlyn wrote:you used sudo chown?


I believe so. But to be honest, I forgot the exact command I used which is why I didn't mention it in my opening post. I'm actually just looking up some commands for this now so I can try again. I will post back with results. Thanks :wink:


Obviously it's not possible to use chown by itself to change the ownership from root to suer. 'sudo' is not just a command like cp and mv. 'sudo', after asking for a password, grants permission to do actions as root.

Since I do not like to type password all the time and when I see I will have to do several actions as root, I simply do: 'sudo su'. Then proceed as root for all other commands. When done with root actions, I do an 'exit'.

This said I have no idea of 'lucky backup' (sounds like a lottery :) ) and use rsync in a script file to do backups after mounting the external USB as root. The script executes as a normal user since of course the external USB drive is owned by the user. It would be a folly to make a backup drive owned by root when only user files are backed up.

Death
Established Member
Posts: 147
Joined: Sun Oct 11, 2015 1:43 pm

Re: Can't take ownership of HDD's as root

Postby Death » Mon Feb 11, 2019 4:37 pm

jonetsu wrote:This said I have no idea of 'lucky backup' (sounds like a lottery :) ) and use rsync in a script file to do backups after mounting the external USB as root. The script executes as a normal user since of course the external USB drive is owned by the user. It would be a folly to make a backup drive owned by root when only user files are backed up.


It's just that everything was working great before. Something has changed and I want to try and figure it out rather than using different methods to back up.

Well I'm not making the backup drive owned by root on purpose. It just is. I want to make it so that my user account owns it. I think this may enable my backups to work again. I don't know what else it could be.

jonetsu
Established Member
Posts: 1400
Joined: Sat Jun 11, 2016 12:05 am

Re: Can't take ownership of HDD's as root

Postby jonetsu » Mon Feb 11, 2019 5:22 pm

Make the mount point belonging to user <name>. For user joe, a mount point of /mnt/disk and an external USB drive of /dev/sde1 :

(as root) chown joe.joe /mnt/disk

Then mount the drive still as root:

mount /dev/sde1

Then open another console and as regular user:

cd /mnt/disk
touch test

If the empty file 'test' is created then the regular user has permission to write.

This said, on Xubuntu 18.04 mount will change the ownership automatically to user, even if the mount point is root just before the mounting.

Death
Established Member
Posts: 147
Joined: Sun Oct 11, 2015 1:43 pm

Re: Can't take ownership of HDD's as root

Postby Death » Mon Feb 11, 2019 6:09 pm

jonetsu wrote:Make the mount point belonging to user <name>. For user joe, a mount point of /mnt/disk and an external USB drive of /dev/sde1 :

(as root) chown joe.joe /mnt/disk

Then mount the drive still as root:

mount /dev/sde1

Then open another console and as regular user:

cd /mnt/disk
touch test

If the empty file 'test' is created then the regular user has permission to write.

This said, on Xubuntu 18.04 mount will change the ownership automatically to user, even if the mount point is root just before the mounting.


On the first step I get

Code: Select all

Operation not permitted


On the second step I get

Code: Select all

FUSE exfat 1.2.8
WARN: volume was not unmounted cleanly.
fuse: mountpoint is not empty
fuse: if you are sure this is safe, use the 'nonempty' mount option


The third step did create the empty 'test' file though. I do now have permission to write to the drive after previously remounting the drive with RW permissions. But my backup program still won't work. It backs up 13.5 MB of data and then just stops. It's only done this since running Photorec the other day. The current errors it's giving are:

Code: Select all

rsync: failed to set times on "(mountpoint/folder)": Operation not permitted (1)


'Preserve ownership, times' is disabled in LuckyBackup due to the fact that 'Destination is FAT/NTFS' is enabled (The backup drive is exfat). So I don't know what else that could mean.. Any ideas?

jonetsu
Established Member
Posts: 1400
Joined: Sat Jun 11, 2016 12:05 am

Re: Can't take ownership of HDD's as root

Postby jonetsu » Mon Feb 11, 2019 6:46 pm

I also get operation not permitted:

chown mevla.mevla /mnt/disk/
chown: changing ownership of '/mnt/disk/': Operation not permitted

This is because I did the command as a regular user. It has to be done as root.

"mountpoint is not empty"

That's because it was already used. It has to be done clean.

It's really simple in the end when one does the steps manually. What the 'lucky' software does is something else but it does use rsync to actually perform the backup. I use rsync from a script I made instead, not from some software. Although there are very good and straightforward and simple backup software.scripts out there. I haven't used any in years so I do not remember names. AFAIC, I would stay away by a few kilometers from a software called 'lucky backup'.

"rsync: failed to set times"

This is probably because the target fs is Windows stuff. Windows fs attributes are not the same as Linux. Why do you use a Windows filesystem to backup a Linux system ? rsync can output errors and still continue its work as much as it can. If the software using rysnc fails on the first error, then the story is not the same.

At all times do a 'ls -l' (or just 'll') to see who owns what.

Death
Established Member
Posts: 147
Joined: Sun Oct 11, 2015 1:43 pm

Re: Can't take ownership of HDD's as root

Postby Death » Mon Feb 11, 2019 7:21 pm

jonetsu wrote:I also get operation not permitted:

chown mevla.mevla /mnt/disk/
chown: changing ownership of '/mnt/disk/': Operation not permitted

This is because I did the command as a regular user. It has to be done as root.

"mountpoint is not empty"

That's because it was already used. It has to be done clean.

It's really simple in the end when one does the steps manually. What the 'lucky' software does is something else but it does use rsync to actually perform the backup. I use rsync from a script I made instead, not from some software. Although there are very good and straightforward and simple backup software.scripts out there. I haven't used any in years so I do not remember names. AFAIC, I would stay away by a few kilometers from a software called 'lucky backup'.

"rsync: failed to set times"

This is probably because the target fs is Windows stuff. Windows fs attributes are not the same as Linux. Why do you use a Windows filesystem to backup a Linux system ? rsync can output errors and still continue its work as much as it can. If the software using rysnc fails on the first error, then the story is not the same.

At all times do a 'ls -l' (or just 'll') to see who owns what.


1. I did run it as root (with sudo before the command) and that was the output I got.

2. "That's because it was already used. It has to be done clean." - how do I do it clean? lol..

3. LuckyBackup has always been good to me until the other day. Like I said, it was something to do with running Photorec (& possibly downgrading my kernel) the other day - it messed with my system somehow. I would use a Rsync script but I like having the GUI as it simplifies things and I just like it, you know? Also, it makes it easy to see and manage snapshots of the backups. I don't even know if that can be done with Rsync via terminal or how you would do it. I imagine it would be clunky as hell comparing files if it's possible.. No thanks to that..

4. Yes, the target is exFAT formatted. I have the relevant option enabled for this which in turn disables the feature that is being complained about in the error. It shouldn't be complaining about it. Still, I don't think this is why the backup stops anyway. Backing up one exFAT drive to another, the same thing happens which is weird - maybe that's a clue?

I use exFAT because I don't need it to be a Linux file system. The files are mostly just general files (media, text files etc). I also need to be able to access them from other operating systems (Windows & Mac, for example) so these two external drives are exFAT. This setup has worked great the entire time until now. I see no reason it needs to be changed. Something has just gone wrong with a configuration somewhere it seems.

5. I ran those two commands but I don't see my drives listed there. It seems to just be, or at least mostly just be ownership & permission stuff for things in my home folder. I will note down those commands for future use though. Thanks!

Sorry if I'm missing any obvious stuff but I'm taking notes and trying to learn as I go here. I'm not familiar in dealing with these issues :shock: I appreciate all the help though.

Edit I just tested running a backup from my Linux system drive to my internal ext4 storage drive without including the external exFAT drives in the backup. LuckyBackup reports these errors which I think may be useful in understanding the issue here:

Code: Select all

rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1196) [sender=3.1.2]


Code: Select all

rsync: opendir "/home/z/.dbus" failed: Permission denied (13)


Code: Select all

rsync: chown "/mnt/ff04ca1e-58e7-4ac2-92b5-78fd02007bc9/1. My stuff/1. Downloads/2. Backups/LuckyBackup/z/.dbus" failed: Operation not permitted (1) rsync: chown "/mnt/ff04ca1e-58e7-4ac2-92b5-78fd02007bc9/1. My stuff/1. Downloads/2. Backups/LuckyBackup/z/.gadmin-rsync" failed: Operation not permitted (1)


Code: Select all

rsync: chown "/mnt/ff04ca1e-58e7-4ac2-92b5-78fd02007bc9/1. My stuff/1. Downloads/2. Backups/LuckyBackup/z/.gadmin-rsync/keys" failed: Operation not permitted (1)


Can anyone make sense of those? Thanks.

jonetsu
Established Member
Posts: 1400
Joined: Sat Jun 11, 2016 12:05 am

Re: Can't take ownership of HDD's as root

Postby jonetsu » Mon Feb 11, 2019 9:22 pm

1. Root can change the ownership. It's as simple as that. There's no 'operation not permitted' for root regarding this, basically.

2. By 'clean' I meant if the device is already used or some condition like this. You printed it in your reply: "fuse: mountpoint is not empty". Eg. it's not clean.

The kernel has nothing to do with this. This is much beyond the kernel. You can argue that the filesystem is part of of the kernel and yes it is, as far as providing the basic services. The management of access is something else unless your are using SELinux.

To see which drive are mounted and where and at the same time to which capacity they are used, use:

df -h

I don't do any diffs with the backups on home systems. Otherwise each backup is done in a folder whose name has the date and time. In ambiguous cases where diffs have to be made, it's only a few text files and that's easily made using for instance emacs. There's no clunkiness in that for the simple reason that it's avoided from the start.

"rsync error: some files/attrs were not transferred "

As I've mentioned, if I would get that kind of error code in my script from rsync and stop the backup then it would be my own (lucky ?) decision. Otherwise this kind of error does not stop rsync.

The other errors such as: "rsync: opendir "/home/z/.dbus" failed: Permission denied (13) " are simple to troubleshoot. Just try them manually and see what the problem is. To do so you first must know how lucky runs, as root or as user ? Then try the same by yourself. This ~/z/.dbus looks strange anyways. Who is user 'z' ? Looks like there's an attempt to open a communication channel within dbus. I do not run dbus on Xubuntu 18.04.

The others like "rsync: chown "/mnt/ff04ca1e-58e7-4ac2-92b5-78fd02007bc9/1. ..." Just try them. What is the user given as argument to chown ?

Making sense of them is easy. There were attempts to change the ownership of a few things and that was not allowed. Duh. Root can change ownerships. Does lucky runs as root ? What if you try it yourself, first as user, then as root ? Why is there a change of ownership in the first place ? Because rsync is run with the -o option ?

Apart for music purposes, document editing and web browsing, I run no GUI really. 8)

Anyways, looks like you're not the only one having that kind of problems with lucky.

merlyn
Established Member
Posts: 369
Joined: Thu Oct 11, 2018 4:13 pm

Re: Can't take ownership of HDD's as root

Postby merlyn » Mon Feb 11, 2019 10:57 pm

Death wrote:"How are they mounted?" Sorry but I'm not sure what you mean by that. Could you elaborate please?


You could mount a drive by

putting an entry in fstab, so it mounts at startup
clicking on it in a file manager
using the mount command from the command line

When a drive is mounted there are options and it may be these options that are the problem.

Death
Established Member
Posts: 147
Joined: Sun Oct 11, 2015 1:43 pm

Re: Can't take ownership of HDD's as root

Postby Death » Tue Feb 12, 2019 1:09 am

jonetsu wrote:1. Root can change the ownership. It's as simple as that. There's no 'operation not permitted' for root regarding this, basically.

2. By 'clean' I meant if the device is already used or some condition like this. You printed it in your reply: "fuse: mountpoint is not empty". Eg. it's not clean.

The kernel has nothing to do with this. This is much beyond the kernel. You can argue that the filesystem is part of of the kernel and yes it is, as far as providing the basic services. The management of access is something else unless your are using SELinux.

To see which drive are mounted and where and at the same time to which capacity they are used, use:

df -h

I don't do any diffs with the backups on home systems. Otherwise each backup is done in a folder whose name has the date and time. In ambiguous cases where diffs have to be made, it's only a few text files and that's easily made using for instance emacs. There's no clunkiness in that for the simple reason that it's avoided from the start.

"rsync error: some files/attrs were not transferred "

As I've mentioned, if I would get that kind of error code in my script from rsync and stop the backup then it would be my own (lucky ?) decision. Otherwise this kind of error does not stop rsync.

The other errors such as: "rsync: opendir "/home/z/.dbus" failed: Permission denied (13) " are simple to troubleshoot. Just try them manually and see what the problem is. To do so you first must know how lucky runs, as root or as user ? Then try the same by yourself. This ~/z/.dbus looks strange anyways. Who is user 'z' ? Looks like there's an attempt to open a communication channel within dbus. I do not run dbus on Xubuntu 18.04.

The others like "rsync: chown "/mnt/ff04ca1e-58e7-4ac2-92b5-78fd02007bc9/1. ..." Just try them. What is the user given as argument to chown ?

Making sense of them is easy. There were attempts to change the ownership of a few things and that was not allowed. Duh. Root can change ownerships. Does lucky runs as root ? What if you try it yourself, first as user, then as root ? Why is there a change of ownership in the first place ? Because rsync is run with the -o option ?

Apart for music purposes, document editing and web browsing, I run no GUI really. 8)

Anyways, looks like you're not the only one having that kind of problems with lucky.


Like I said, I tried it as root and that was the output I got. Maybe that indicates a problem?

I don't even know what .dbus is but you need to be root to open it. z is my user account, btw. LuckyBackup is not running as root and I've always done it this way but it does have an "attempt super-user activitites" option which is enabled. I have found a separate launcher to run it as a 'super-user' though so I'm just giving that a shot now..

Using sudo chown with the internal ext4 storage drive returns nothing. But when I check the permissions on that drive, it's owned by my user account which is probably why backups actually work and run through to the end on that drive. When I try with the two external exFAT drives, I get the same 'Operation not permitted' output from the terminal.

I think LuckyBackup likes the user running the tasks to be the owner of the drives. I remember reading something on their site about it and some explanation about why they made the option to run the program as a super-user harder to find. I think they also said that it's better if the user just owns the drives rather than running the 'Attempt super-user activities' command, but that this command was useful when the user doesn't own the drives. I forget the exact details of what was said though so I may have gotten that a bit wrong there..

merlyn wrote:
Death wrote:"How are they mounted?" Sorry but I'm not sure what you mean by that. Could you elaborate please?


You could mount a drive by

putting an entry in fstab, so it mounts at startup
clicking on it in a file manager
using the mount command from the command line

When a drive is mounted there are options and it may be these options that are the problem.


I see.

My internal ext4 storage drive (which I have ownership of and bacups are working fine with) is mounted at startup. I believe I set that up via the file managers GUI which I assume modified the fstab file.

The two external exFAT drives are not always plugged in - only when I run backups. I'm not sure if they mount automatically or if it's when I click on them in the file manager. They do show up on my desktop as mounted drives right after plugging them in though so I assume they automatically mount once plugged in?

Cheers guys. Really appreciate the help! As I said, I'm currently running LuckyBackup as a super-user so I'll see what happens..

merlyn
Established Member
Posts: 369
Joined: Thu Oct 11, 2018 4:13 pm

Re: Can't take ownership of HDD's as root

Postby merlyn » Tue Feb 12, 2019 1:39 am

Death wrote:They do show up on my desktop as mounted drives right after plugging them in though so I assume they automatically mount once plugged in?


Yes, that sounds like they're automatically mounted. That means you have a package installed to do that. You can see the options they were mounted with using:

Code: Select all

cat /proc/mounts|grep /dev/


I'm not sure about exfat but fat has an option to specify the UID (user id) that the filesystem is mounted with. The default is the process that mounted it. You'll have to scroll down quite far, :) but it's here :

Code: Select all

man mount

User avatar
milo
Established Member
Posts: 175
Joined: Wed Sep 06, 2017 2:55 am
Location: Southern Utah, USA
Contact:

Re: Can't take ownership of HDD's as root

Postby milo » Tue Feb 12, 2019 9:46 pm

Death, I can empathize with your frustrations. I have a little headless Linux box set up as a NAS on my home network, and it seems like every time I try to set up a new machine I forget how to do it and end up beating my head against the wall for hours trying to get the new machine to mount the network drive with read/write permissions. I try various iterations of chown, using the terminal and a file explorer with su privileges, forgetting and then remembering to use the -r recursive flag. And then finally I remember to mount with the uid option in fstab . . . and that magically solves the problem!

I really need to write these things down so that I don't have to struggle to find the same solutions every time I set up a machine.

FWIW, and this may not help you at all with the problems you describe, but I have had great success with rsnapshot (https://rsnapshot.org/). It is basically an rsync script on steroids, and it has some really handy features. It aggressively uses hard links to save storage space on your backup device. It is not a gui app, but setup and config isn't too hard and the HOWTO document is pretty good: https://rsnapshot.org/rsnapshot/docs/docbook/rest.html

Death
Established Member
Posts: 147
Joined: Sun Oct 11, 2015 1:43 pm

Re: Can't take ownership of HDD's as root

Postby Death » Tue Feb 12, 2019 11:15 pm

So. I ran LuckyBackup as 'super-user' and my backups worked fine again. So it looks like I was right with my initial idea - the backups weren't working properly because I no longer own the drives.

So basically, if I can just get ownership of the drives again I can go back to what I was previously doing. Getting ownership of the drives is proving extremely difficult though as we've seen.. But if anyone has any other ideas on how to do that, I'm listening!

merlyn wrote:
Death wrote:They do show up on my desktop as mounted drives right after plugging them in though so I assume they automatically mount once plugged in?


Yes, that sounds like they're automatically mounted. That means you have a package installed to do that. You can see the options they were mounted with using:

Code: Select all

cat /proc/mounts|grep /dev/


I'm not sure about exfat but fat has an option to specify the UID (user id) that the filesystem is mounted with. The default is the process that mounted it. You'll have to scroll down quite far, :) but it's here :

Code: Select all

man mount


Code: Select all

z@z-System-Product-Name:~$ cat /proc/mounts|grep /dev/
devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000 0 0
/dev/mapper/mint--vg-root / ext4 rw,relatime,errors=remount-ro,data=ordered 0 0
tmpfs /dev/shm tmpfs rw,nosuid,nodev 0 0
mqueue /dev/mqueue mqueue rw,relatime 0 0
hugetlbfs /dev/hugepages hugetlbfs rw,relatime,pagesize=2M 0 0
/dev/sda1 /boot/efi vfat rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro 0 0
/dev/sdb1 /mnt/ff04ca1e-58e7-4ac2-92b5-78fd02007bc9 ext4 rw,nosuid,nodev,relatime,data=ordered 0 0
/dev/fuse /run/user/1000/doc fuse rw,nosuid,nodev,relatime,user_id=1000,group_id=1000 0 0


I'm not sure what most of that stuff means :/

So much stuff comes up with that second command :o I don't even know what I'm looking for in there. But, I'm pretty sure I already set my system up to mount via UUID because the mount points for my drives are all this big hash of numbers and letters. Or am I misunderstanding how this works?

milo wrote:Death, I can empathize with your frustrations. I have a little headless Linux box set up as a NAS on my home network, and it seems like every time I try to set up a new machine I forget how to do it and end up beating my head against the wall for hours trying to get the new machine to mount the network drive with read/write permissions. I try various iterations of chown, using the terminal and a file explorer with su privileges, forgetting and then remembering to use the -r recursive flag. And then finally I remember to mount with the uid option in fstab . . . and that magically solves the problem!

I really need to write these things down so that I don't have to struggle to find the same solutions every time I set up a machine.

FWIW, and this may not help you at all with the problems you describe, but I have had great success with rsnapshot (https://rsnapshot.org/). It is basically an rsync script on steroids, and it has some really handy features. It aggressively uses hard links to save storage space on your backup device. It is not a gui app, but setup and config isn't too hard and the HOWTO document is pretty good: https://rsnapshot.org/rsnapshot/docs/docbook/rest.html


Yeh dude haha.. I've had various goes at Linux as my main OS over the past 10 years or something and always went back to Windows because I just wanted to use my computer instead of spending so much time troubleshooting and pissing around with the terminal ;( I've just come back to Linux as my main and only operating system this year. So I've only been back a matter of months now and have had to re-learn basically from scratch. It's gone much better this time than my previous attempts though. But HDD stuff always seems to cause me the most trouble. It's crazy how hard it is just to setup some bloody hard drives sometimes...

I think the fstab has already been modified by the GUI in Mint when I set stuff up. But I should probably take a look at it and learn what to do with it. I remember messing around in there in my previous install. I wish I could just be lazy and do everything by the GUI, but Linux keeps showing me that it's not good enough to think like that. YOU MUST BECOME A TERMINAL MASTER! :lol:

I take notes often but I can only really write them down once I understand what they mean, otherwise it's just a load of crap which makes no sense to me. I had that when I looked at all my old notes from last time I used Linux :shock: This is why I'll probably have to go through this situation another couple times before I can write some decent notes on it.

Everyone keeps mentioning my backup program, but I knew there was nothing wrong with it and that it didn't need changing. It was just a permissions/ownership thing as I initially thought which my test today confirmed. Still, I'll take a look at the one you mentioned just out of interest ;)

Cheers all!

merlyn
Established Member
Posts: 369
Joined: Thu Oct 11, 2018 4:13 pm

Re: Can't take ownership of HDD's as root

Postby merlyn » Tue Feb 12, 2019 11:35 pm

I don't see an exfat drive in /proc/mounts

What do we know?

(1) It used to work.
(2) The dastardly Photorec came along, changed the mount options and now it doesn't work.

Solution : reset the application that auto-mounts usb drives to its defaults, which hopefully is how it was before Photorec.


Return to “Linux Distributions & Other Software”

Who is online

Users browsing this forum: No registered users and 2 guests