Worse performance when power supply plugged in!

Optimize your system for ultimate performance.

Moderators: khz, MattKingUSA

Musicteacher
Established Member
Posts: 167
Joined: Mon Nov 13, 2017 5:54 am

Re: Worse performance when power supply plugged in!

Postby Musicteacher » Thu Jun 06, 2019 9:44 am

I have taken a look (even though the gig is still to come, but a bios setting is undone faster than a kernel upgrade).

There are two settings that can be changed in this bios:

- intel speed step

The problem is that when I de-activate intel speed step, the cpu runs on a fixed rate of 1.4 gHz, whereas my own tests showed that the cpu can run at a rate of 1.8 gHz for a longer time (3.4 gHz is the max turbo boost frequency, but this cannot be kept up when using more than 1 core). So if I de-activate intel speed-step, I loose cpu power. I decided not to do that.

- processor power management. This controls the sleep-states. If I change that, it seems that nothing changes. i7z shows that still the cpu enters c1 state (the others are turned of by myself).

The lenovo bios on the L380 is not very powerful. If you buy a professional-grade lenovo machine, there are much more settings.

Jack Winter
Established Member
Posts: 376
Joined: Sun May 28, 2017 3:52 pm

Re: Worse performance when power supply plugged in!

Postby Jack Winter » Thu Jun 06, 2019 9:54 am

No thermal shutdown msgs in the output of dmesg? ;)

This is a really curious problem. According to the cyclictest/hwlatdetect results there are no problems with kernel scheduling nor with NMI/SMIs. I'd suggest though to run both for a longer time. Run cyclictest during an entire cycle of, on battery, charging, on external power, and then do the same with hwlatdetect. These utilities might need to run for an extensive time to catch the problem.
Reaper/KDE/Archlinux. i7-2600k/16GB + i7-4700HQ/16GB, RME Multiface/Babyface, Behringer X32, WA273-EQ, 2 x WA-412, ADL-600, Tegeler TRC, etc 8) For REAPER on Linux information: https://wiki.cockos.com/wiki/index.php/REAPER_for_Linux

merlyn
Established Member
Posts: 369
Joined: Thu Oct 11, 2018 4:13 pm

Re: Worse performance when power supply plugged in!

Postby merlyn » Thu Jun 06, 2019 12:44 pm

Musicteacher wrote:a bios setting is undone faster than a kernel upgrade

It's possible to have multiple kernels e.g. linux, linux-rt and linux-rt-lts installed and choose the one you want at boot with grub.

User avatar
langoring_composer
Established Member
Posts: 12
Joined: Fri May 24, 2019 10:32 pm

yeah, i believe the guy

Postby langoring_composer » Fri Jun 07, 2019 9:41 pm

He might not want to disable hyperthreading. However, sometimes it's tied to ACPI (APCI?) anyways power-related stuff so it can't be done independently. Also, these days, power components of laptops have miniature computer-like parts inside of them and can be hacked from the AC outlets which can also be repurposed as radio antennas. (ya learn weird stuff from studying the Sharper Image and RadioShack catalogs along with taking stuff apart and going to college classes).

In some studios, they use power line conditioners to filter out some of that riff raff which they used to call "RF" (radio frequency) interference. But then again, that RF stuff might have been PCM data signtals sent into gear to mess with it (as long as it complies with CFR FCC rules!).

Musicteacher
Established Member
Posts: 167
Joined: Mon Nov 13, 2017 5:54 am

Re: Worse performance when power supply plugged in!

Postby Musicteacher » Tue Jun 11, 2019 8:47 am

Hi,
I do switch off hyperthreading.

In another thread I read that the general jack-realtime-priority should be lower than that of the soundcard.

Is it correct that I set the realtime-priority for jack in limits.conf and the one for the soundcard with rtirq ?

If so, are 95 for the soundcard and 80 for the rest a good value?

merlyn
Established Member
Posts: 369
Joined: Thu Oct 11, 2018 4:13 pm

Re: Worse performance when power supply plugged in!

Postby merlyn » Tue Jun 11, 2019 11:15 am

Musicteacher wrote:Is it correct that I set the realtime-priority for jack in limits.conf and the one for the soundcard with rtirq ?

limits.conf is a global maximum. The priority of JACK is set when you start it. On Cadence there's a box to set this, there will be on QJackctl too. rtirq sets the priority of the soundcard interrupt.

Having the soundcard at 95 and JACK at 85 works.


Return to “System Tuning and Configuration”

Who is online

Users browsing this forum: No registered users and 1 guest