Switching from Jack2 to Jack1

Optimize your system for ultimate performance.

Moderators: khz, MattKingUSA

User avatar
LinMusGuy
Established Member
Posts: 157
Joined: Wed Feb 27, 2019 9:33 pm

Switching from Jack2 to Jack1

Postby LinMusGuy » Mon Apr 08, 2019 12:38 pm

After switching from Jack2 to Jack1 I get this warning in the terminal:

Code: Select all

jackd 0.122.0
Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details


JACK is running in realtime mode, but you are not allowed to use realtime scheduling.
Please check your /etc/security/limits.conf for the following line
and correct/add it if necessary:

  @audio          -       rtprio          99

After applying these changes, please re-login in order for them to take effect.

You don't appear to have a sane system configuration. It is very likely that you
encounter xruns. Please apply all the above mentioned changes and start jack again!


How serious is this. What if I just disable realtime mode in Jack?

User avatar
sysrqer
Established Member
Posts: 1823
Joined: Thu Nov 14, 2013 11:47 pm
Contact:

Re: Switching from Jack2 to Jack1

Postby sysrqer » Mon Apr 08, 2019 1:03 pm

Just make the change it suggests, it's only adding a line to a file.

User avatar
LinMusGuy
Established Member
Posts: 157
Joined: Wed Feb 27, 2019 9:33 pm

Re: Switching from Jack2 to Jack1

Postby LinMusGuy » Tue Apr 09, 2019 7:46 pm

I have added myself to the "audio group" with:

Code: Select all

sudo usermod -a -G audio USERNAME


Looks like this solved the issue.


Return to “System Tuning and Configuration”

Who is online

Users browsing this forum: No registered users and 1 guest