Help.. Nvidia GPU trumps my soundcard..

Optimize your system for ultimate performance.

Moderators: khz, MattKingUSA

Eddyness
Established Member
Posts: 6
Joined: Tue Mar 19, 2019 5:14 pm

Help.. Nvidia GPU trumps my soundcard..

Postby Eddyness » Tue Mar 19, 2019 9:38 pm

Hi All..

Tried KXstudio a year ago, could not get any sound out if it so ended up with Linux Mint.. Fast forward to today and I took the plunge again and now have KXstudio on my system again, and again.. no sound..
Refused to give up this time and I think I have finally narrowed it down to my Nvidia 1080 constantly showing up as the default sound device.. Have been seeing an unbelievable amount of posts with folk having the same probs. Lot of peeps thought Nvidia would make a simple switch in the driver to turn the GPU audio off, but it does not not look like that has happened..

My sound card is a Scarlett 2i4 USB and I need to configure my system so that it is the default sound card, and ideally, I would like to stop KXstudio from thinking my Nvidia is anything other than my graphics card..
Apologies if this has been dealt with before, have waded through a lot of posts on this forum trying to find something similar and have spent a fair while trying to go through the extensive user guide for KXstudio, which has resulted in more heat than light..

Could be wrong, but I think I have to alter a .conf file (alsa-config?) but being utterly new to KXstudio, I really dont want to start off in the wrong direction..

Any help please? Not used to my computer being silent..!

User avatar
Linuxmusician01
Established Member
Posts: 697
Joined: Mon Feb 23, 2015 2:38 pm
Location: Holland

Re: Help.. Nvidia GPU trumps my soundcard..

Postby Linuxmusician01 » Wed Mar 20, 2019 12:55 pm

This, indeed, is a problem a lot of us have. The audio card/audio device that we humans consider our number one audio card is not what Linux considers the first audio device to go to. I think that what you call your video card is actually an on board audio chip that, of course, behaves like an audio card.

There are two solutions for this classic problem. One is to get ALSA to change the "numbering" of your audio devices so that the Scarlett external USB audio card is number one and the Nvidia card is number two.

The best solution, if you ask me, is to tell your audio software to use the Scarlett and nothing else. Here's where things start to get hairy because this is the point where we Linuxers advice you to use Jack as a layer on ALSA. Why? I still don't know why we Linuxers use Jack, I've just come to accept it. ;)

First determine the "number" of your USB audio card. I always do this like so:

Code: Select all

cat /proc/asound/cards

Output looks something like this:

Code: Select all

$ cat /proc/asound/cards
 0 [CMI8738        ]: CMI8738-MC6 - C-Media CMI8738
                      C-Media CMI8738 (model 55) at 0xd000, irq 20
 1 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7c10000 irq 45
 2 [U192k          ]: USB-Audio - UMC404HD 192k
                      BEHRINGER UMC404HD 192k at usb-0000:00:1a.0-1.2, high speed

As you can see, I have no less than 3 audio cards/audio devices on my computer. A PCI C-Media audio card (number 0 because ALSA starts numbering at zero), an on boad audio card from my Intel video card and an external USB audio device just like you. My USB audio device is from Behringer, yours of course should show up as "number 1" (because Alsa starts numbering at 0) and it should have the Scarlett name brand or something.

Now start Jack, telling it to use card number 1 (i.e. your second audio device) and telling it to use Alsa as an audio driver:

Code: Select all

jackd -d alsa --device hw:1


Now start your favorite audio software (e.g. Audacity, Reaper, Ableton Live, what have you not) and tell it to use Jack for audio. After that you'll have a thousand more questions because it's bound not to work as simple as that. This forum is meant for those questions. One tip on beforehand: you might want to use a program called qjackctl to connect your Midi keyboard to your DAW etc. If you click on the button "connect" you'll see what you can connect. Look under the tab "Alsa" for Midi (the "Midi" tab is Jack's midi which I never use), and under the tab "Audio" are your audio in- and outputs. See example screenshot:

Image

Pretty complicated, innit? Good luck and don't give up! :)


P.S. I wrote a little shell script for myself for things like this, its here.
Last edited by Linuxmusician01 on Wed Mar 20, 2019 8:26 pm, edited 1 time in total.

merlyn
Established Member
Posts: 573
Joined: Thu Oct 11, 2018 4:13 pm

Re: Help.. Nvidia GPU trumps my soundcard..

Postby merlyn » Wed Mar 20, 2019 4:56 pm

@Eddyness You may not have to change the default soundcard.

When you boot KX Studio JACK is started. JACK takes over the audio system. If you tell JACK to use the Scarlett it always will. KX uses Cadence to control JACK. Launch Cadence, stop JACK, click on 'Configure', select the 'Driver' tab, untick 'Duplex', select the Scarlett from the drop-down and restart JACK. These settings are written to an xml file and will be loaded at startup.

I can see that it might bug you that you that the Scarlett isn't the default, but the above should work.

User avatar
nikgnomicradio
Established Member
Posts: 90
Joined: Wed Feb 07, 2018 9:31 pm
Contact:

Re: Help.. Nvidia GPU trumps my soundcard..

Postby nikgnomicradio » Fri Mar 22, 2019 4:15 pm

nvidia GPU grabbing the default hw:0 slot in ALSA is very common

If you can live without an onboard audio device, simple way to get rid of GPU in ALSA is blacklist the snd_hda_intel driver

For most Linux versions using systemd, need to create a file in /etc/modprobe.d/

echo -e "blacklist snd_hda_intel" | sudo tee -a /etc/modprobe.d/HDAblacklist.conf

(name of file can be anything you like as long as it ends with '.conf' )

User avatar
Linuxmusician01
Established Member
Posts: 697
Joined: Mon Feb 23, 2015 2:38 pm
Location: Holland

Re: Help.. Nvidia GPU trumps my soundcard..

Postby Linuxmusician01 » Fri Mar 22, 2019 4:50 pm

Topic starter seems to have lost interest... :roll:

Eddyness
Established Member
Posts: 6
Joined: Tue Mar 19, 2019 5:14 pm

Re: Help.. Nvidia GPU trumps my soundcard..

Postby Eddyness » Fri Sep 27, 2019 10:44 am

Hi..
Sorry for the very late reply, not lost interest but had to start up a new business, start home education of my son and my synth died.. sigh..

got all that fixed, new synth and thank you nikgnomicradio, did a bit of research and have now blacklisted the GPU audio by modifying the blacklist.conf file (was already there, did not need to create it) by adding the line 'blacklist snd_hda_intel' to it, saving and a quick reboot.. sorted..!!

User avatar
Michael Willis
Established Member
Posts: 908
Joined: Mon Oct 03, 2016 3:27 pm
Location: Rocky Mountains, North America
Contact:

Re: Help.. Nvidia GPU trumps my soundcard..

Postby Michael Willis » Fri Sep 27, 2019 7:10 pm

Eddyness wrote:Hi..
Sorry for the very late reply, not lost interest but had to start up a new business, start home education of my son and my synth died.. sigh..

Wow, I glanced over that message and saw something about new business, home education, and my son died... I'm glad to re-read it and find out that your son is not dead.

Eddyness
Established Member
Posts: 6
Joined: Tue Mar 19, 2019 5:14 pm

Re: Help.. Nvidia GPU trumps my soundcard..

Postby Eddyness » Fri Sep 27, 2019 9:29 pm

Wow x 2.. My son will be glad to hear that.. want to borrow my reading glasses? :shock:


Return to “System Tuning and Configuration”

Who is online

Users browsing this forum: No registered users and 2 guests