Useful tips when using Cadence to control the Jack server

Optimize your system for ultimate performance.

Moderators: khz, MattKingUSA

User avatar
thetotalchaos
Established Member
Posts: 144
Joined: Mon Sep 29, 2014 8:29 pm
Contact:

Useful tips when using Cadence to control the Jack server

Postby thetotalchaos » Sun Nov 12, 2017 6:54 pm

There is an issue i am experiencing, when i install and use Cadence to control the Jack server.
It creates a virtual alsa-loop device, which often claims to be the default audio device.
My solution (that i think should be somehow implemented by default), is to make a script that makes my hardware soundcard to be my top device.
So i create a file: /etc/modprobe.d/alsa-base.conf that contains this lines.

Code: Select all

options snd_aloop index=-2
options snd_usb_audio index=-2


The devices may vary depending of your hardware, but the idea is that i move the alsa-loop and usb-audio (my MIDI Keyboard) at the bottom of the audio devices list.
Another issue appears, because i use Gnome and SystemD. They have a pulseaudio.socket that launches the pulseaudio server before Cadence starts the Jack server. In this case i have another solution. I disable the pulseaudio socket, thus leaving Cadence to be in control.
To disable pulseaudio.socket, i make a folder ~/.config/systemd/user/ and then run the following:

Code: Select all

systemctl --user mask pulseaudio.socket


I hope this can help making your Linux Audio experience a little bit smoother. :)
Check out my latest music album The girl with the stars in her eyes
https://totalchaos-music.bandcamp.com/album/the-girl-with-the-stars-in-her-eyes

Return to “System Tuning and Configuration”

Who is online

Users browsing this forum: No registered users and 3 guests