HDSPmixer missing in ubuntu 11.04 - a fix

What other apps and distros do you use to round out your studio?

Moderators: khz, MattKingUSA

HDSPmixer missing in ubuntu 11.04 - a fix

Postby larz » Sat May 14, 2011 9:18 pm

Just a word of warning and a workaround for those who want to upgrade/install ubuntu 11.04 and who owns a RME HDSP card. The alsa-tools-gui package is broken and the HDSP mixer is missing from the install of said package.

There's an "easy" workaround though. Install the Debian Sid package instead - and remember to lock it, otherwise it will upgrade to the broken ubuntu package.
Afterwards you can join the bug-report here (I've posted the links for the debian package needed in comment #14): https://bugs.launchpad.net/ubuntu/+sour ... bug/723276

I don't know if this also is the case in ubuntu-studio as I just installed from the standard ubuntu CD.

Also, I don't know if this is the case if you upgrade from ubuntu to kxstudio.
larz
Establlshed Member
 
Posts: 16
Joined: Thu Jun 04, 2009 12:30 pm

Re: HDSPmixer missing in ubuntu 11.04 - a fix

Postby falkTX » Tue May 24, 2011 2:46 am

larz wrote:Just a word of warning and a workaround for those who want to upgrade/install ubuntu 11.04 and who owns a RME HDSP card. The alsa-tools-gui package is broken and the HDSP mixer is missing from the install of said package.

There's an "easy" workaround though. Install the Debian Sid package instead - and remember to lock it, otherwise it will upgrade to the broken ubuntu package.
Afterwards you can join the bug-report here (I've posted the links for the debian package needed in comment #14): https://bugs.launchpad.net/ubuntu/+sour ... bug/723276

I don't know if this also is the case in ubuntu-studio as I just installed from the standard ubuntu CD.

Also, I don't know if this is the case if you upgrade from ubuntu to kxstudio.


I notice this a few hours ago, the solution could not be simpler - just rebuild alsa-tools.
The problem is that this alsa-tools version should be built against the latest alsa-lib (1.0.24), but it didn't happen in Ubuntu...
A simple rebuild is enough to fix this... LOL
(fixed in the kx-team repos now)
User avatar
falkTX
Establlshed Member
 
Posts: 4008
Joined: Sat Jan 09, 2010 3:04 pm

Re: HDSPmixer missing in ubuntu 11.04 - a fix

Postby bearblock » Sat Jun 18, 2011 6:51 pm

hi

I'm also trying to get an RME HDSP working in Natty Narwhal. No devices are listed under Sound Properties > Hardware, but when I run aplay -l in the terminal I can see my card. Is this due to the lack of hdspmixer or is this a different problem?

in the bug report, it says that alsa-tools needs to be rebuilt, but from a previous version. could someone please post the terminal commands that will do this?

I'm trying to learn more about Linux in general but I'd like to be able to listen to music while I do so :)

thanks
bearblock
Establlshed Member
 
Posts: 7
Joined: Sat Jun 18, 2011 6:03 pm

Re: HDSPmixer missing in ubuntu 11.04 - a fix

Postby larz » Sun Jun 19, 2011 11:39 am

What OS are you running?
Did you install alsa-firmware-loaders?
Did you install alsa-tools-gui.
You also will have to start hdspmixer, which you'll have install if you install the packages mentioned above.
And you will probably have to fiddle with the settings in hdspmixer - you can start by trying the presets.
larz
Establlshed Member
 
Posts: 16
Joined: Thu Jun 04, 2009 12:30 pm

Re: HDSPmixer missing in ubuntu 11.04 - a fix

Postby bearblock » Mon Jun 20, 2011 8:59 pm

What OS are you running?


Ubuntu 11.04

Did you install alsa-firmware-loaders?
Did you install alsa-tools-gui.


I've run sudo apt-get install alsa-firmware-loaders and sudo apt-get install alsa-tools-gui at the console, both of which seemed to do their thing without any errors.

You also will have to start hdspmixer, which you'll have install if you install the packages mentioned above.


hdspmixer: command not found
bearblock
Establlshed Member
 
Posts: 7
Joined: Sat Jun 18, 2011 6:03 pm

Re: HDSPmixer missing in ubuntu 11.04 - a fix

Postby larz » Tue Jun 21, 2011 11:54 am

Exactly. Then you have the problem I described in my first post.
See comment #14 in this bug report:
https://bugs.launchpad.net/ubuntu/+sour ... bug/723276
You will have to know if you're running 32 or 64 bit to get the right package.
If you're not sure, you can check it by running:
Code: Select all
uname -a

When you've downloaded the correct file, open a terminal, cd to the right dir, and install with:
Code: Select all
sudo dpkg -i nameOfFile

Following that it should be possible to hold the package (so it doesn't automatically update to the later version with:
Code: Select all
sudo aptitude hold alsa-tools-gui



Maybe you want hdspmixer to start up automatically when it all works. Then you should make a startup script with something like this:
Code: Select all
#!/bin/sh
hdsploader
hdspmixer & sleep 3 && killall hdspmixer
larz
Establlshed Member
 
Posts: 16
Joined: Thu Jun 04, 2009 12:30 pm

Re: HDSPmixer missing in ubuntu 11.04 - a fix

Postby bearblock » Wed Jun 22, 2011 6:29 pm

Ok cool, so now I can run the hdspmixer - but still no sound. When I run pacmd list it reports no cards found. It looks like ALSA is detecting the card, but PulseAudio isn't.
bearblock
Establlshed Member
 
Posts: 7
Joined: Sat Jun 18, 2011 6:03 pm

Re: HDSPmixer missing in ubuntu 11.04 - a fix

Postby larz » Wed Jun 22, 2011 8:36 pm

Sorry bearblock. I forgot all about this.

There is one more thing you have to do.
Code: Select all
gksu gedit /etc/pulse/default.pa

Find where it says
Code: Select all
Load audio drivers statically... bla bla...

In that text block you should add 2 lines:
Code: Select all
load-module module-alsa-sink device_id=0 tsched=0
load-module module-alsa-source device_id=0 tsched=0

Save and reboot.
Now fiddle with the hdspmixer again to see if you can get some sound.
larz
Establlshed Member
 
Posts: 16
Joined: Thu Jun 04, 2009 12:30 pm

Re: HDSPmixer missing in ubuntu 11.04 - a fix

Postby bearblock » Thu Jun 23, 2011 8:57 pm

Ok we have sound! There are a few minor snags (hdspmixer faders don't do anything, pulseaudio channel mapping seems a bit weird) but for my purposes it will do nicely. Many thanks for all the help larz :D
bearblock
Establlshed Member
 
Posts: 7
Joined: Sat Jun 18, 2011 6:03 pm

Re: HDSPmixer missing in ubuntu 11.04 - a fix

Postby larz » Fri Jun 24, 2011 9:57 am

Nice :)
How well do you know the hdspmixer? At least for me that was a problem in the beginning. I thought the same as you until I found out what the different sliders were actually for. And a lot of them, in my case, were just for ins/outs that I weren't connected, so naturally they had no effect.
You can however remap stuff. I think you can find the mixer manual on RME's site. Just play around with it.
But I'm happy you have sound.
larz
Establlshed Member
 
Posts: 16
Joined: Thu Jun 04, 2009 12:30 pm

Re: HDSPmixer missing in ubuntu 11.04 - a fix

Postby falkTX » Fri Jul 22, 2011 5:45 pm

(ignore this)
Last edited by falkTX on Sun Jul 31, 2011 1:29 pm, edited 1 time in total.
User avatar
falkTX
Establlshed Member
 
Posts: 4008
Joined: Sat Jan 09, 2010 3:04 pm

Re: HDSPmixer missing in ubuntu 11.04 - a fix

Postby larz » Fri Jul 22, 2011 9:16 pm

What a sad waste of computer power...
larz
Establlshed Member
 
Posts: 16
Joined: Thu Jun 04, 2009 12:30 pm

Re: HDSPmixer missing in ubuntu 11.04 - a fix

Postby bearblock » Sun Jul 24, 2011 2:21 pm

hi, me again with a mute ubuntu :(

i installed some updates when prompted by the ubuntu software centre, including pulseaudio from 1:0.9.22+stable-queue-24-g67d18-0ubuntu3 to 1:0.9.22+stable-queue-24-g67d18-0ubuntu3.1. now the volume control icon in the system tray has disappeared, and i get a new error when running pulseaudio from the terminal:

Code: Select all
E: module-alsa-card.c: Failed to find a working profile.
E: module.c: Failed to load  module "module-alsa-card" (argument: "device_id="0" name="pci-0000_08_01.0" card_name="alsa_card.pci-0000_08_01.0" tsched=yes ignore_dB=no card_properties="module-udev-detect.discovered=1""): initialization failed.


I tried commenting out the two lines i previously added to default.pa, but that doesn't seem to make much difference.

Then i tried going back to the old pulseaudio version:

Code: Select all
sudo apt-get install pulseaudio=1:0.9.22+stable-queue-24-g67d18-0ubuntu3


and i get this error:

Code: Select all
The following packages have unmet dependencies.
 pulseaudio : Depends: libpulse0 (= 1:0.9.22+stable-queue-24-g67d18-0ubuntu3) but 1:0.9.22+stable-queue-24-g67d18-0ubuntu3.1 is to be installed
E: Broken packages


any ideas?
bearblock
Establlshed Member
 
Posts: 7
Joined: Sat Jun 18, 2011 6:03 pm

Re: HDSPmixer missing in ubuntu 11.04 - a fix

Postby larz » Sun Jul 24, 2011 5:20 pm

Did anything happen to the changes we made in the configuration file as per post #12?
larz
Establlshed Member
 
Posts: 16
Joined: Thu Jun 04, 2009 12:30 pm

Re: HDSPmixer missing in ubuntu 11.04 - a fix

Postby bearblock » Sun Jul 24, 2011 6:24 pm

post 12? do you mean these:

Code: Select all
load-module module-alsa-sink device_id=0 tsched=0
load-module module-alsa-source device_id=0 tsched=0


i've tried it both with and without those lines in the config - same error either way.
bearblock
Establlshed Member
 
Posts: 7
Joined: Sat Jun 18, 2011 6:03 pm

Next

Return to Linux Distributions & Other Software

Who is online

Users browsing this forum: No registered users and 1 guest